
Impedance Matching of Filters with the MSA
Sam Wetterlin

2/11/11

Introduction

The purpose of this document is to illustrate the process for impedance matching of 
filters using the MSA software. For example, commercial crystal filters typically specify 
the components to be used to terminate the filter, such as 2.5 kOhms plus shunt 3 pF at 
the filter terminals. There are many ways to accomplish this. Conceptually, the simplest is 
to place capacitors at the terminals and then connect the source and load through 
transformers with the proper impedance ratio.

If you actually have specs for the filter, all you need to do is rig up the proper matching 
components. But if you built the filter yourself, or you bought a surplus filter with 
unknown specs, you need to figure out what terminating components to use. That is what is 
explained in this document.

In summary, the procedure is to obtain two-port S-parameters for the filter, and then to 
simulate performance with various terminating components. The version of the MSA 
software soon to be released includes a Two-Port Window whose function is to assemble or 
load S-parameters, graph the various individual parameters, and graph the performance 
with specified terminations.

Gathering the S-parameters by Scanning

The first step is to obtain S-Parameters. Presently, the MSA will gather transmission or 
reflection data, which is often referred to as S21 and S11 data. Depending on the 
orientation of the DUT, the data might really be S12 or S22 (for a reversed DUT). But 
when you have gathered only a single parameter, the labeling is not that critical. 

If you have gathered a transmission or reflection S-Parameter, you will want to create a 
set of two-port S-parameters that incorporates that data. Two-port S-parameters include 
four parameters: S11 (forward reflection coefficient), S21 (forward gain), S12 (reverse 
gain) and S22 (reverse reflection coefficients). The “reflection coefficients” are generally 
expressed in dB/angle form, in which case they might be called return loss, though 
technically return loss is expressed with a positive dB value. The forward and reverse gain 
are actually the device gain only if the source and load match the S-parameter reference 
parameters, typically 50 ohms.



You can gather transmission data in Transmission mode by the normal process, then gather 
Reflection data by the normal process and then use menu Two-Port->Display Two-Port 
WindowA new graph window will be opened (and the original is disabled). . If the two-port 
parameters are empty, as they will be the first time through, a dialog will open allowing you 
to transfer the existing reflection and transmission data to the two-port parameters:

Figure 1—Parameter transfer dialog

The dialog in Figure 1 has an active checkbox for transferring Transmission or Reflection. 
If there is no scan data for one of those, its checkbox would be grayed. When you click 
one of these boxes, the checkboxes to its right will be activated, and you can transfer the 
parameter to one or both of the indicated S parameters.

For a filter, S21 and S12 should be equal, so it makes sense to transfer the transmission 
data to both S21 and S12. It is possible for S11 and S22 to differ, but unless the filter 
was designed for different input and output impedances, S11 and S22 are likely close 
enough that you can transfer your reflection data to both S11 and S22. While this may 
create some error, the fact is that whatever terminating components we ultimately 
determine, variation in real-world components means you likely need to fine tune the 
physical impedance matching components anyway. But if you want to be more precise, you 
can transfer the reflection data to S11, close the Two-Port window and then go back and 
scan reflection of the DUT in reverse. Then re-open the Two-Port window, which will still 
have the data you entered earlier. Click the Get Scan Data button, and you will get the 
same dialog shown in Figure 1, and can transfer the reflection data to S22.

Once you have the parameters assembled, you can use menu File->Save Two-Port Params to 
save them as an s2p file (Touchstone format).

Loading the S-Parameters from a file

If you already have a file of two-port S-parameters, you can use the Two-Port window’s 
menu File->Load Parameters to load them into the window’s two-port array.  If you have 
individual S21 and S11 files, you can load them the same way, and you will be given options 
as to where to transfer them. If you use individual parameter files, you should first click 
the button Clear All Params in order to start with a clean slate. When you clear the 
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parameters, or when you open the Two-Port window before having added any parameters, 
the parameter data is initialized to -199 dB. This represents negligible reflection or 
transmission, similar to a circuit with 50 ohm shunt resistors at input and output, with the 
resistors connected through a third, huge resistor. If you load S11 parameters, you are 
basically replacing the input resistor with an impedance corresponding to your new data. 
Your S11 data actually represents a one-port device, but it is now incorporated into a two-
port device so the methods of the Two-Port window can be applied. For example, you can 
use the impedance matching methods described below and simply ignore information 
relating to the output.

Graphing the Parameters

Once you have a full set of two-port parameters in place, you can graph any of them by 
simply clicking the corresponding button.

Figure 2—Graph of filter S21 data

(You may note that the display of MHz/Div was incorrect at the time these screen shots 
were taken.)

Figure 2 graphs S21 for my filter, whose parameters were loaded from a file. The graph 
and marker buttons are similar to the MSA main graph window. S21 magnitude is in blue, 
and makes a terrible filter because it is not seeing the proper source and load. In this 
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graph, you can double-click in the area of the Y-axis numeric labels to get a dialog allowing 
you to change color and width of the traces, and the Y-axis range. You can double-click on 
the title area to change the title. Double-clicking below the frequency axis does nothing.

The eight buttons on the right are used to select the data to be graphed; the S21 button 
is in bold because that is the parameter being graphed.  The S11-S22 buttons graph the 
parameters exactly as they have been loaded. The matched S11-S22 buttons  graph the S-
parameters of a circuit created by adding certain impedance matching to the input and 
output of the device.

The S-parameter file used here contained 800 steps. To reduce the number of steps and 
thereby speed up calculations, I wanted to trim off the outermost points, away from the 
filter peak.  I did this setting the L marker somewhat left of the viewable data and the R 
marker somewhat to the right, as shown in Figure 3.

Figure 3—Graph of S21 with L and R markers placed for trimming. 

I then used menu Edit->Modify params which provides three ways to alter the parameters. 
The first is to keep only the data between the L and R markers, which is the option I used. 
The second option is to eliminate every other point, which is handy for reducing the size of 
unnecessarily dense S-parameter files. The third option is to specify a new frequency 
range and number of steps, which interpolates the existing data to a new set of 
parameters.
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Figure 4—Graph of S21 after excess points trimmed
P+ marker has also been added.

Figure 4 shows the graph after trimming. I then changed the graph from S21 to Matched 
S21, and obtained Figure 5.

Figure 5—Graph of Matched S21, with default matching

The graph of Figure 5 shows Matched S21 and is identical to the regular S21 of Figure 4. 
That is because the default match is 50 ohms with a shunt 0 pF capacitor at each filter 
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terminal. ). When one of the matched parameters is selected lines 2 and 3 of the title 
describe the matching, and the Change Termination button is displayed.

The Actual Impedance Matching Process

If we click the Change Terminations button shown in Figure 5, we can change the 
impedance matching via the dialog shown in Figure 6.

Figure 6—Impedance Matching Dialog with Default Values 

The dialog of Figure 6 allows changing the impedance matching components, and also allows 
selection of any of the matched S-Parameters. The selected parameter will be graphed in 
the Two-Port window. This dialog can be moved as necessary to make the full graph visible.
The impedance match is specified separately for the source and load. The specified 
resistance is matched with a theoretical transformer that transforms between that 
resistance and the S-parameter reference impedance, here 50 ohms. In addition, a 
capacitor or inductor can be placed between the transformer and the filter, either in 
series or shunt to ground. Here, the default 0 pF capacitors are shown in the shunt 
configuration.

We can enter values manually, or use the Auto Match Buttons. Auto Match calculates 
component values that achieve conjugate matching at the input and/or output. That is, the 
impedance seen by the specified filter port is the complex conjugate of the filter’s input 
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or output impedance. “AutoMatch—Simultaneous” achieves a simultaneous conjugate match 
at both the filter input and output. This simultaneous match takes into account the fact 
that, as soon as you add terminating components to the output, you change the input 
impedance, and therefore change the required input matching components. Likewise, as 
soon as you add the input components, you change the required output matching 
components. Figure 7 shows the result of clicking AutoMatch--Simultaneous, after first 
specifying a frequency of 10.697 MHz.

Figure 7—Impedance Matching Dialog with Auto Match Values 
Note this screen-shot was taken with an earlier version

that had a slightly different format.

Note that the impedance matching capacitor values produced by Auto Match are 
negative. We specified that the reactive component must be a shunt capacitor. In 
fact, an inductance is what is required. But a negative capacitance is another way 
to specify an inductance, and as described later it can be a very convenient way to 
do so. Figure 8 shows the graph of S21 with the Auto Match matching components. 
(The scale has been changed to focus on the peak.)
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Figure 8—Matched S21 per Auto Match at 10.697 MHz 

Insertion loss in Figure 8 is quite low, but there is an ugly glitch in the peak. The 
fact that simultaneous conjugate matching has been achieved does not necessarily 
mean that we have the perfect match. The filter response may be cleaner with a 
match at a different frequency. Figure 9 shows the graph with the Auto Match 
redone at 10.698 MHz.

Figure 9—Matched S21 per Auto Match at 10.698 MHz

The glitch that was on the peak in Figure 8 remains where it was, but the peak in Figure 9 
has shifted to the right, and the glitch is not as bothersome. Note that this glitch may be 
a real-world characteristic of the filter, or it may be an artifact created by measurement 
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error. Small measurement errors get magnified when substantial impedance 
transformations are made.

You can adjust the frequency used by Auto Match to get the best-looking response, or you 
can directly alter the impedance matching components and redraw the graph.

Impedance Match Topology and Negative Capacitance

Let’s assume that the optimal source impedance match is 1000 ohms resistance and a shunt 
-3 pF capacitor; as described below, that -3 pF capacitance in the real world represents an 
inductance whose impedance at the calculation frequency (here, assume an even 10.7 MHz) 
equals the negative of the impedance of a 3 pF capacitor. This would be a 74 uH inductor 
(L=1/[4π2f2C]). That’s not a very practical inductance at 10.7 MHz, but we’ll get around 
that in a minute.

As noted above, the MSA software assumes impedance matching with a transformer and a 
capacitor or inductor. But there are other ways to do it. A common way to do it is the low-
pass L filter, as shown in Figure 10.

Figure 10—LC replacement for input transformer
Flip both circuits horizontally for the output

The LC filter on the right makes the same transformation as the transformer on the left, 
in the vicinity of 10.7 MHz, “vicinity” typically meaning within several hundred kHz. The 
exact LC values actually depend on the Q of the inductor; here a Q of 100 was assumed. 
These values can easily be calculated using the impedance match button of RFSim99, which 
will create the necessary circuit components. You can then adjust the inductor L values to 
something realistic and tweak the component values to get the desired transformation. 
Large impedance transformations are especially sensitive to inductor Q. For example, if 
Q=20 (typical of SMT inductors at 10.7 MHz), getting the correct resistance 
transformation may require designing the match for 50:1250 rather than 50:1000.

Either circuit of Figure 10 can be used to make the 50:1000 ohm match at the input, and 
they can be reversed to make the output match. In addition, we have to place the shunt 
capacitor, which we will set to -3 pF. Consider the circuit of Figure 11.
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Figure 11—Adding a negative capacitance to the input impedance match
Again, flip horizontally for the output

The normal rules for parallel capacitors can be applied—we just add the two capacitance 
values on the left to get the single capacitor on the right. Whenever this impedance match 
topology is going to be used, it is very handy to use the shunt capacitor in the dialog of 
Figure 7. Whether the result is a positive or negative capacitance, it can be merged with 
the capacitor of the resistive impedance match LC circuit.

What About S11/S22?

Figure 12 shows a graph of Matched S11, using Auto Match at 10.698 MHz.

Figure 12—S11 with simultaneous conjugate matching

Conjugate matching assures that S11 and S22 will be excellent at that frequency. 
However, S11 is not nearly as good elsewhere in the pass band.  S11 and S22 are mainly 
important because the reflections they represent may have an indirect effect on the 
transmission of the filter. But bottom line, when the filter is put to actual use, its 
transmission characteristics are usually all you really care about, unless the source or load 
are especially sensitive to the filter impedance. Finally, the user may be willing to sacrifice 
a little bit of efficiency at the peak to obtain a better overall response shape. 
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Therefore, it makes more sense to focus on the matched S21 graph when adjusting the 
impedance matching components. But you can easily click the matched S11 or S21 buttons 
if you want to view the reflection side of things. Once you get close to the proper match, 
small changes in component values may cause very small changes in matched S21, but may 
make more dramatic improvements in matched S11 or matched S22.  

Figure 12A shows that it is possible to graph several parameters at once. By clicking 
“Matched S21” and then shift-clicking “Matched S11” and “Matched S22”, all three 
parameters are shown at once. Because each parameter includes two parts—dB and angle—
this can make a messy graph. Therefore, the trace width for the left axis was set to zero, 
so none of the angles actually gets graphed.

Figure 12A—Matched S21, S11 and S22 on one graph
Angle graphs are turned off by setting trace width=0

Note that the marker information in Figure 12A shows only the first parameters selected, 
in this case Matched S21.

Physical Adjustment in the Real World

In the real world, there will be uncertainty as actual source/load impedances, component 
values, inductor Q, transformer ratios, and parasitics. In addition, the LC match of Figure 
10 always seems to provide some residual capacitance on the filter side. 

It is advisable to provide for fine-tuning the physical impedance matching circuit.  With 
the match of Figure 11, this could be done by using a variable capacitor in place of the 62 
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pF capacitor. Finer control could be obtained with a variable 3-30 pF capacitor in parallel 
with a 47 pF capacitor. If desired, when a suitable match is obtained, the variable 
capacitor can be removed and measured, and replaced with a fixed capacitor.

Frequency Range of Analysis

Finally, the use of LC impedance matches to replace transformers, as well as the 
usefulness of negative capacitance, depend on the fact that L and C impedances vary only a 
small amount within the bandwidth of the filter. For filters with bandwidths less than 1% 
of the center frequency, this is a good assumption when evaluating performance in and 
around the pass band. The impedance matching graphs of the MSA software are intended 
to be used within such narrow ranges, though in fact the assumed matching topology, using 
a transformer, will provide an accurate graph over a much broader range. But for a view of 
performance over a broad frequency range when the transformer is replaced with LC 
matching, it is necessary to insert the matching components into a simulator such as 
RFSim99 and graph over the desired range. 

There are special considerations regarding negative capacitors and inductors. A negative 
capacitance, for example, represents a physical inductance, but the inductance value varies 
over frequency. If we actually simulated over a broad frequency range using a negative 
capacitance, the magnitude of the impedance of that capacitor would decrease as 
frequency increased. That would be unrealistic behavior for the inductance the negative 
capacitor is supposed to represent. Accordingly, when a matched parameter is graphed, 
negative capacitors are converted to positive inductors to do the calculations. Likewise, 
negative inductors are converted to positive capacitors. The conversion is done at the 
“Calculation Frequency” shown in the dialog of Figure 7, which is also the frequency at 
which Auto Match calculates the matching components.
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Relationship of Z0 Transformations to Impedance Matching

Figure 13 shows our filter matched with 900 ohms on each side.

Figure 13—Filter matched with 900 ohms on each side

Figure 14 shows the same filter, with no matching components, and its reference 
impedance (Z0) changed to 900 ohms.

Figure 14—Original parameters converted to Z0=1000 ohms

The Z0 transformation was accomplished by double-clicking on the Z0 value at the upper 
right of the graph (which of course then read Z0=50.00), and entering the new value in the 
dialog that opens. The result is identical to the impedance matching of Figure 13.
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This illustrates that if you want to make a purely resistive impedance transformation, 
equally to the input and output, all you need to do is convert Z0 to the desired resistance.
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